Opened 9 years ago

Closed 9 years ago

#274 closed defect (fixed)

Upgrading the Illumina package does not update the validator path fo BGX files

Reported by: Jari Häkkinen Owned by: Nicklas Nordborg
Priority: major Milestone: Illumina package v1.6
Component: net.sf.basedb.illumina Keywords:
Cc:

Description (last modified by Jari Häkkinen)

When I install new versions of plug-ins I copy the files to a new sub-directory named after the plug-in together with the version number. In this case illumina-plugins-1.5.1. I follow the upgrade instructions in the INSTALL (v1.5.1) file. Everything seems okay until I try to add a new Illumina array design. BASE complains and says that the BGX validator path is not correct. BASE is of course correct, the path still points at the old now removed jar-file. Curiously the SNP validator path is correctly pointing at the new jar-file.

The work around is to manually set the new path.

Change History (4)

comment:1 Changed 9 years ago by Jari Häkkinen

Description: modified (diff)

comment:2 Changed 9 years ago by Nicklas Nordborg

The installation program is a bit inconsistent. It can create three platform variants: Expression 1, Expression 2 and SNP. The default selection when they already exists is "no". The "no" on SNP is actually ignored and the installation will create/update the SNP file types no matter what. The "no" on the expression platforms is not ignored. I think the proper solution is to have "yes" as the default selection and then fix the installation so that the SNP option is not ignored.

comment:3 Changed 9 years ago by Nicklas Nordborg

Status: newassigned

comment:4 Changed 9 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [1237]) Fixes #274: Upgrading the Illumina package does not update the validator path fo BGX files

Note: See TracTickets for help on using tickets.