Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#311 closed task (fixed)

Updates required for BASE 3 support

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: blocker Milestone: Illumina package v1.7
Component: net.sf.basedb.illumina Keywords:
Cc:

Description (last modified by Nicklas Nordborg)

Need to make some packaging changes. Eg. Plugin definitions should be moved into extensions.xml. Plugin configurations file should be renamed to plugin-configurations.xml. Build script changes needed since BASE jar file have different names. See the net.sf.basedb.examples build script for ideas.

Verify that the plug-ins work with BASE 3.

Big changes in the data file validation mechanism (http://base.thep.lu.se/ticket/1598). This package includes BgxFileHandler and SnpCvsFileHandler. We need to convert them to extensions and fix the installation program for data file types.

Change History (6)

comment:1 Changed 8 years ago by Nicklas Nordborg

Description: modified (diff)

comment:2 Changed 8 years ago by Nicklas Nordborg

Description: modified (diff)

comment:3 Changed 8 years ago by Nicklas Nordborg

Milestone: Illumina package v1.xIllumina package v1.7

comment:4 Changed 8 years ago by Martin Svensson

(In [1385]) References #311 The Illumina plugin package can now be build with base3-jars and install in BASE3.0

comment:5 Changed 8 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [1386]) Fixes #311: Updates required for BASE 3 support

BGX and SNP manifest file validation seems to be working. Updated readme and installation instructions.

comment:6 Changed 8 years ago by Nicklas Nordborg

(In [1445]) References #311: Updates required for BASE 3 support

Need to renamed the plug-in configurations file.

Note: See TracTickets for help on using tickets.