Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#320 closed defect (worksforme)

reggie 1.4 (and 1.3): cannot save if no PADCase is entered in some cases

Reported by: Jari Häkkinen Owned by: Jari Häkkinen
Priority: critical Milestone:
Component: net.sf.basedb.reggie Keywords:
Cc:

Description (last modified by Nicklas Nordborg)

Note! After investigation of this problem it was found to be related to empty "Sampling date" and "RNA Later date" and has been replaced with #323. The description below does not apply.


When a specimen tube exists in BASE without a PADCase annotation, and reggie is used to enter Case information for the tube reggie refuses to let the registrar to save if no PADCase is entered.

If there is no specimen tube in BASE then reggie will accept the creation of Case without PADCase annotations.

reggie should allow registration of Case without entering PADCase information since PADCase information is often missing at registration and entered later.

This is a critical issue since it is quite common use case.

Change History (3)

comment:1 Changed 8 years ago by Nicklas Nordborg

I am not able to reproduce this. I can create a case without PAD even when specimen tubes exists. Later on, I can update the existing case with a PAD.

comment:2 Changed 8 years ago by Nicklas Nordborg

Component: not classifiednet.sf.basedb.reggie
Description: modified (diff)
Milestone: Reggie v1.5
Resolution: worksforme
Status: newclosed
Type: Requestdefect

Hmm... I tried some other variants and I am pretty sure the problem is with empty "Sampling date" and "RNA Later date". If I give values for them, I can save with an empty PAD. If there are no date+time values, it doesn't matter if a PAD is given or not. The "Create" button doesn't work.

There is a workaround... Use 'Tab' (or the mouse) to step through the input fields so that each date+time box is selected and deselected at least once. The "Create" button will now work.

I think the problem is that when the form is loaded all fields starts out in 'invalid' state. Each field is usually validated when it loses the input focus. Empty date+time are considered valid by the validation function, but this is only called when:

  1. There are date+time values when the form is loaded
  2. The date+time fields are deselected

The solution is that the "Sampling date" and "RNA Later date" should start in 'valid' state when the form is loaded.

comment:3 Changed 8 years ago by Nicklas Nordborg

Description: modified (diff)
Note: See TracTickets for help on using tickets.