Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#125 closed task (fixed)

Create test suite

Reported by: Jari Häkkinen Owned by: Jari Häkkinen
Priority: major Milestone: 0.6
Component: test Version: trunk
Keywords: Cc:

Description

A test suite must be designed. There are many simple solutions to this that cannot be used since the repository should be portable, i.e., the tests should work off-line. The problem is to make the testrepo shareable over the net, but also independent of the net in a test situation.

Change History (5)

comment:1 Changed 14 years ago by Peter Johansson

(In [239]) Creating branch for improving test suite. refs #125

comment:2 Changed 14 years ago by Peter Johansson

(In [242]) initial ci of test repo refs #125

comment:3 Changed 14 years ago by Peter Johansson

(In [246]) the file and directory tests are obsolete and therefore removed if WCTEST is true test_repo.sh is created which runs svndigest on a the toy repository refs #125

comment:4 Changed 14 years ago by Peter Johansson

Resolution: fixed
Status: newclosed

(In [248]) fixes #125

comment:5 Changed 14 years ago by Peter Johansson

(In [274]) support for Trac. Fixes #125. Also added a config file.

Note: See TracTickets for help on using tickets.