Opened 13 years ago

Closed 13 years ago

#278 closed task (fixed)

Dates on blame listing of files have incorrect colour

Reported by: Jari Häkkinen Owned by: Peter Johansson
Priority: major Milestone: svndigest 0.6.5
Component: output Version: 0.6.4
Keywords: Cc:

Description

See http://www.thep.lu.se/~jari/svndigest/yat/all/total/configure.ac.html where some dates are with a white font colour.

Change History (5)

comment:1 Changed 13 years ago by Jari Häkkinen

Version: trunk0.6.4

comment:2 Changed 13 years ago by Peter Johansson

The color is actually #fbfbfb.

Moreover, line 74 (an empty line) is dated to 19 Feb 03 (rev 2) and still the font is very black. Something is rotten here. The problem is most likely in functions File::print_blame or hex.

comment:3 Changed 13 years ago by Peter Johansson

I have found the problem.

last = Date(GnuplotFE::instance()->dates().back()).seconds();
first = Date(GnuplotFE::instance()->dates()[0]).seconds();

assumes that the earliest date corresponds to revision 0, which we know is false for yat.

comment:4 Changed 13 years ago by Peter Johansson

(In [502]) Hopefully fixes this, but I keep the ticket open until we have a new run on yat.

comment:5 Changed 13 years ago by Peter Johansson

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.