Opened 13 years ago

Closed 12 years ago

#324 closed defect (fixed)

copyright update fails on doc/readme.txt

Reported by: Peter Johansson Owned by: Jari Häkkinen
Priority: major Milestone: svndigest 0.7
Component: svncopyright Version: trunk
Keywords: Cc:

Description (last modified by Peter Johansson)

ticket:354 is related

The problem is that the string Copyright (C) first detected does not belong to the actual copyright but to some text describing how the copyright update is detecting where the Copyright...grrr.

Change History (6)

comment:1 Changed 13 years ago by Peter Johansson

Milestone: svndigest 0.x+svndigest 0.7

We have to take care of this before release, or at least remember to edit this file manually.

comment:2 Changed 13 years ago by Peter Johansson

Description: modified (diff)

ticket:354 was marked as related

comment:3 Changed 12 years ago by Peter Johansson

Easiest solution would be to move Copyright block from footer to header.

comment:4 in reply to:  3 Changed 12 years ago by Jari Häkkinen

Replying to peter:

Easiest solution would be to move Copyright block from footer to header.

But there are many files that have the copyright block in the footer ... or is this issue specific for the doc/readme.txt file?

comment:5 Changed 12 years ago by Peter Johansson

Well, the problem is how the copyright block is detected. As we say in doc/readme.txt the copyright block is detected as the first line containing "Copyright (C)". The problem with readme.txt is that the first "Copyright (C)" is not in the copyright block, but in the body text where we describe about copyright detection.

If we moved the copyright block to the header, the first copyright detected would be the one in the copyright block and problem is solved.

comment:6 Changed 12 years ago by Peter Johansson

Resolution: fixed
Status: newclosed

(In [813]) Putting copyright statement in top of file. fixes #324.

Note: See TracTickets for help on using tickets.