Opened 11 years ago

Closed 11 years ago

#415 closed defect (fixed)

copyright update crashes on mixed revision wc

Reported by: Peter Johansson Owned by: Peter Johansson
Priority: major Milestone: svndigest 0.7.1
Component: svncopyright Version: 0.7
Keywords: Cc:

Description

I've experienced problems (mostly assertions) when running on a mixed revision wc. We should check this early and exit/fail.

Change History (3)

comment:1 Changed 11 years ago by Peter Johansson

Milestone: svndigest 0.8svndigest 0.7.1
Owner: changed from Jari Häkkinen to Peter Johansson
Status: newassigned
Version: trunk0.7

I have an idea what the cause of the problem is. If I'm right I'll fix the problem in 0.7-stable instead and skip the new requirement.

comment:2 Changed 11 years ago by Peter Johansson

Component: corecopyright
Summary: require that <ROOT> wc is at a non-mixed revisioncopyright update crashes on mixed revision wc
Type: taskdefect

comment:3 Changed 11 years ago by Peter Johansson

Resolution: fixed
Status: assignedclosed

(In [933]) fixes #415

Note: See TracTickets for help on using tickets.