Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#428 closed task (fixed)

plplot 5.9.6 dependency

Reported by: Jari Häkkinen Owned by: Jari Häkkinen
Priority: blocker Milestone: svndigest 0.8
Component: core Version: trunk
Keywords: Cc:

Description

Finalization of the milestone:"svndigest 0.8" depend on the release of plplot 5.9.6 due to a serious bug in C++ support in 5.9.5 and lower versions.

The plplot development site is http://plplot.sourceforge.net/

Change History (8)

comment:1 Changed 10 years ago by Jari Häkkinen

plplot 2.9.5 was released more than 6 months ago and still no 2.9.6 released. I have asked the plplot devel forum about their time line for releasing 2.9.6, https://sourceforge.net/projects/plplot/forums/forum/131157/topic/3647704

comment:2 Changed 9 years ago by Peter Johansson

plplot 5.9.6 was release June 5th

comment:3 Changed 9 years ago by Jari Häkkinen

Status: newassigned

I'll look into this. I hope the plplot port maintainer upgrades to the latest version soon.

comment:4 Changed 9 years ago by Jari Häkkinen

I have added an update request to the macports trac system, https://trac.macports.org/ticket/25879

comment:5 Changed 9 years ago by Peter Johansson

Plplot is updated in macports and stable-branch 0.8pre works fine.

I suppose we should update version requirement (configure.ac and README) and then we can close this ticket.

comment:6 Changed 9 years ago by Jari Häkkinen

I am working on this. My macports was broken and rather than starting over with a clean setup I fixed the issues. It was not the time efficient choice and I think I did not learn anything during the process. It took me a couple of nights to fix ... and now I have an port based plplot 5.9.6 installed. I'll have o break here but I'll continue later this evening.

Soon we'll have the 0.8 release.

comment:7 Changed 9 years ago by Jari Häkkinen

Resolution: fixed
Status: assignedclosed

Well, the 0.8 is still not ready to be released since we have problems with the tests (ticket:469). However, plplot 5.9.6 is released and is now available also through macports.

comment:8 Changed 9 years ago by Peter Johansson

(In [1161]) require plplot 5.9.6. refs #428

Note: See TracTickets for help on using tickets.