Opened 5 years ago

Closed 5 years ago

#527 closed defect (fixed)

macports svndigest, and make check, fails on Mac OS 10.10 (Yosemite)

Reported by: Jari Häkkinen Owned by: Jari Häkkinen
Priority: major Milestone: svndigest 0.10.1
Component: output Version: 0.10
Keywords: Cc:

Description

Testing with svndigest-0.10 from subversion repository yields the below test results. The same holds for the trunk version.

PASS: cache.test
PASS: cache_partial.test
PASS: color.test
PASS: config.test
PASS: copyright.test
PASS: date.test
PASS: graph.test
../autotools/test-driver: line 107: 31776 Segmentation fault: 11  "$@" > $log_file 2>&1
FAIL: htmlstream.test
PASS: ignore_rev.test
PASS: parser.test
PASS: option.test
PASS: stats.test
PASS: svn_diff.test
../autotools/test-driver: line 107: 31822 Segmentation fault: 11  "$@" > $log_file 2>&1
FAIL: trac.test
PASS: utility.test
PASS: vector.test
PASS: cmd_format_test.sh
PASS: config2_test.sh
PASS: config3_test.sh
PASS: config_props_test.sh
PASS: copyright2_test.sh
PASS: copyright_cache_test.sh
PASS: error_test.sh
PASS: ignore_revs_test.sh
FAIL: link_root_test.sh
PASS: permission_test.sh
PASS: remove_cache_test.sh
PASS: repo_status_test.sh
FAIL: repo_test.sh
PASS: svncopyright_test.sh
PASS: svndigest_copy_cache_test.sh
PASS: svndigest_copy_cache_test2.sh
PASS: traverse_test.sh
PASS: try_help_test.sh
============================================================================
Testsuite summary for svndigest 0.10.1pre
============================================================================
# TOTAL: 34
# PASS:  30
# SKIP:  0
# XFAIL: 0
# FAIL:  4
# XPASS: 0
# ERROR: 0
============================================================================
See test/test-suite.log
Please report to svndigest-users@lists.sourceforge.net
============================================================================

Change History (7)

comment:1 Changed 5 years ago by Jari Häkkinen

Status: newassigned

After some digging I realize that the issue is in the HtmlStream class

comment:2 Changed 5 years ago by Jari Häkkinen

(In [1563]) Addresses #527. The initialization of the HtmlStream? parent class (ostream) was incorrect.

comment:3 Changed 5 years ago by Jari Häkkinen

Resolution: fixed
Status: assignedclosed

(In [1564]) Fixes #527. The initialization of the HtmlStream? parent class (ostream) was incorrect.

comment:4 Changed 5 years ago by Jari Häkkinen

Milestone: svndigest 0.x+svndigest 0.10.1

comment:5 Changed 5 years ago by Peter Johansson

(In [1565]) Extend test of HtmlStream? to expose bug introduced in changeset r1563. refs #527.

comment:6 Changed 5 years ago by Peter Johansson

Component: testoutput
Resolution: fixed
Status: closedreopened
Version: trunk0.10

comment:7 Changed 5 years ago by Peter Johansson

Resolution: fixed
Status: reopenedclosed

(In [1567]) fix inaccurate test code which caused spurious test failure; closes #527 (again!)

Note: See TracTickets for help on using tickets.