Opened 14 years ago

Closed 13 years ago

#208 closed enhancement (fixed)

Update Requirements on wiki:start

Reported by: Peter Owned by: Jari Häkkinen
Priority: minor Milestone: yat 0.4
Component: documentation Version: trunk
Keywords: Cc:

Description

What is needed to use yat?

A compiler is not really enough is it? What about automake, autoconf, libtools, documentation stuff like Doxygen (not really a requirement but needed if you want the dox). Do we have any idea about versions neede3d for the autotools?

Change History (8)

comment:1 Changed 14 years ago by Jari Häkkinen

Milestone: 0.3 (Public release)0.4

comment:2 Changed 13 years ago by Jari Häkkinen

Status: newassigned

comment:3 Changed 13 years ago by Jari Häkkinen

doxygen 1.5.x is required (1.5.5 tested by me), or at least 1.4.x does not work.

comment:4 in reply to:  3 ; Changed 13 years ago by Markus Ringnér

Replying to jari:

doxygen 1.5.x is required (1.5.5 tested by me), or at least 1.4.x does not work.

How did 1.4.x fail? I upgraded one of my machines to 1.5.4 from 1.3.4 today. And while the layout is much nicer with 1.5.4, I did not see that 1.3.4 barfed on more things in our documentation than 1.5.4.

comment:5 in reply to:  4 Changed 13 years ago by Peter

Replying to markus:

Replying to jari:

doxygen 1.5.x is required (1.5.5 tested by me), or at least 1.4.x does not work.

How did 1.4.x fail? I upgraded one of my machines to 1.5.4 from 1.3.4 today. And while the layout is much nicer with 1.5.4, I did not see that 1.3.4 barfed on more things in our documentation than 1.5.4.

I remember I changed something in doxygen config file when I was down under. I cant remember what it was, and looking in the log doesnt really help. Yet, I remember I asked you guys via email if it was ok to require later version of Doxygen. Too bad I didnt communicate through Trac.

comment:6 in reply to:  4 Changed 13 years ago by Jari Häkkinen

Replying to markus:

Replying to jari:

doxygen 1.5.x is required (1.5.5 tested by me), or at least 1.4.x does not work.

How did 1.4.x fail? I upgraded one of my machines to 1.5.4 from 1.3.4 today. And while the layout is much nicer with 1.5.4, I did not see that 1.3.4 barfed on more things in our documentation than 1.5.4.

It could just be the doxygen I had, I got a core dump. Updating to the latest doxygen resolved the issue, so I did not look deeper.

comment:7 Changed 13 years ago by Jari Häkkinen

sed is required. You may think sed is everywhere but I got problem with it. Adding check to configure.ac

comment:8 Changed 13 years ago by Jari Häkkinen

Resolution: fixed
Status: assignedclosed

Fixed in changeset:1262

Note: See TracTickets for help on using tickets.