Opened 14 years ago

Closed 13 years ago

#224 closed request (fixed)

Test Suite Class

Reported by: Peter Owned by: Jari Häkkinen
Priority: major Milestone: yat 0.4
Component: test Version: trunk
Keywords: Cc:

Description

Clearly we need a supporting class in the tests.

Possible features:

Taking care of parsing cmd to know if we are in verbose mode. Class should have a function returning std::cout& (or ref to a /dev/null ofstream). Similarly for std::cerr.

A function (outside class) checking if two double are close. Either just check something like {fabs(rhs-lhs)<margin} or rather somthing based on the relative difference.

By design these functionality shall be independent of the library. Remember the Chicken and the Egg. If a bug in test:Suite causes a failed test is not good; but if a bug in the lib causes bad behaviour of test::Suite which in turn causes a failed test, well then it is a mess. To avoid this to happen, make this functionality independent of the yat lib.

Change History (2)

comment:1 Changed 13 years ago by Jari Häkkinen

Milestone: 0.40.5

comment:2 Changed 13 years ago by Peter

Milestone: yat 0.5yat 0.4
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.