Opened 13 years ago

Closed 13 years ago

#376 closed defect (fixed)

configure reports flag info that may be misleading

Reported by: Peter Owned by: Jari Häkkinen
Priority: minor Milestone: yat 0.5
Component: build Version: trunk
Keywords: Cc:

Description

In end of confiugure.ac we have these lines

AC_MSG_NOTICE([  CPPFLAGS=\"$CPPFLAGS\"])
AC_MSG_NOTICE([  CXXFLAGS=\"$CXXFLAGS\"])
AC_MSG_NOTICE([  LIBS=\"$LIBS\"])
AC_MSG_NOTICE([  LDFLAGS=\"$LDFLAGS\"])

giving a summary flags that will be used during build. These are somewhat misleading since they only show half monty. A couple of flags are set in Makefile.am in AM_ namespace, for example, in yat.am states

AM_CPPFLAGS = -I$(top_srcdir) $(GSL_CFLAGS) $(BOOST_CPPFLAGS)

Because AM_CPPFLAGS and CPPFLAGS have very similar roles in Makefiles it is misleading to only show one part. Typically AM_CPPFLAGS is used for flags that are required for the build (e.g. where to find GSL header files), whereas CPPFLAGS can be used for some default setting such as -DNDEBUG.

The problem is that configure has no idea about automake and cannot therefore not report any AM_ *FLAGS.

Change History (2)

comment:1 Changed 13 years ago by Peter

comment:2 Changed 13 years ago by Peter

Milestone: yat 0.x+yat 0.5
Resolution: fixed
Status: newclosed

fixed in [1348]

Note: See TracTickets for help on using tickets.