Opened 13 years ago

Closed 12 years ago

#386 closed defect (fixed)

AX_PATH_GSL doesn't check for GSL header files

Reported by: Peter Owned by: Peter
Priority: trivial Milestone: yat 0.6
Component: build Version: trunk
Keywords: Cc:

Description

I tried removing gsl header files, and the macro goes through without whining a bit.

It is a bit strange because they call a AC_TRY_RUN in which they check the version, well they compare the version given by the user and the version returned by gsl-config. They do not compare the version with the version returned from libgsl or the one defined gsl_version.h.

Anyway, perhaps we should add some tests since AX_PATH_GSL does not provide them. For instance we could try compiling (and linking) against gsl_cdf_hypergeometric_P since this is the reason we require GSL 1.8. Remember: prefer checking functionality rather than version.

Change History (3)

comment:1 Changed 12 years ago by Jari Häkkinen

Milestone: yat 0.x+yat 0.6

comment:2 Changed 12 years ago by Peter

Owner: changed from Jari Häkkinen to Peter
Status: newassigned

In discussion off-trac I mentioned this ticket might be invalid, but I managed to reproduce the problem now.

I will add a test checking if sufficiently new gsl headers are available. I'll place the test in a separate file because I think the configure.ac is growing BIG.

comment:3 Changed 12 years ago by Peter

Resolution: fixed
Status: assignedclosed

(In [1895]) fixes #386. Add test that gsl header files are available. Add 'GSL_CONFIG --cflags' to CPPFLAGS (unless it's a default path) to make the test work also when header files are installed in non-standard location. The flag is stored and used downstream.

Note: See TracTickets for help on using tickets.