Opened 15 years ago

Closed 15 years ago

Last modified 14 years ago

#41 closed defect (fixed)

averager_test fails using compiler optimization flags

Reported by: Jari Häkkinen Owned by: Peter
Priority: major Milestone:
Component: statistics Version: trunk
Keywords: Cc:

Description

Using optimization flags CXXFLAGS="-O3 -Wall -pedantic" CPPFLAGS="-DNDEBUG -DGSL_RANGE_CHECK_OFF -DHAVE_INLINE=1" makes averager_test to fail. If the subversion checked in flags are used, CXXFLAGS="-g -O -Wall -pedantic" CPPFLAGS="-DHAVE_INLINE=1" the test passes.

How does this affect you? The production version of c++_tools is always optimized for speed. However, until the issue is fixed, the subversion flags will be used for the production library. Please report to Jari when this issue is fixed.

Change History (2)

comment:1 Changed 15 years ago by Peter

Resolution: fixed
Status: newclosed

Fixed. Use gcc 4 or later.

comment:2 Changed 14 years ago by wwwrun

Milestone: weighted statistics

Milestone weighted statistics deleted

Note: See TracTickets for help on using tickets.