Opened 12 years ago

Closed 12 years ago

#416 closed enhancement (fixed)

Move normalization functions/classes to a new directory

Reported by: Jari Häkkinen Owned by: Peter
Priority: major Milestone: yat 0.5
Component: utility Version: trunk
Keywords: Cc:

Description

We will probably have several normalization algorithms in yat. Move current normalizers to .../yat/normalize and, of course, add new normalizers here.

Change History (10)

comment:1 Changed 12 years ago by Peter

All other namespaces are nouns such as utility, random, classification, statistics, and regression, and not verbs such as utilize, randomize, classify, (how do you verbalize statistics?), or regress. I think we should stay with that style because it makes it uniform, in other words, I would prefer normalization rather than normalize.

When we have decided on the name, initial things to do are

  • add the directory
  • fix the build to include the new directory
  • add component in Trac
  • add namespace in doc/namespaces.doxygen

comment:2 in reply to:  1 Changed 12 years ago by Jari Häkkinen

Replying to peter:

normalization is okay with me.

comment:3 Changed 12 years ago by Peter

Owner: changed from Jari Häkkinen to Peter
Status: newassigned

comment:4 Changed 12 years ago by Peter

(In [1429]) refs #416 - added directory and modified build

comment:5 Changed 12 years ago by Peter

(In [1430]) added blurp in namespaces.doxygen - refs #416

comment:6 Changed 12 years ago by Peter

rev [1429] does not compile because there is no source for the normalization lib. I'll fix it tomorrow, Monday.

comment:7 Changed 12 years ago by Peter

(In [1432]) refs #416 moving quantile normalizer to new dir. Also moved the algorithm to a class (rather than free function).

comment:8 Changed 12 years ago by Peter

Resolution: fixed
Status: assignedclosed

comment:9 Changed 12 years ago by Peter

Resolution: fixed
Status: closedreopened

I've changed my mind regarding the name and will change to normalizer, which is in line with classifier.

comment:10 Changed 12 years ago by Peter

Resolution: fixed
Status: reopenedclosed

(In [1497]) changing name to normalizer - closes #416

Note: See TracTickets for help on using tickets.