Opened 12 years ago

Closed 12 years ago

#487 closed enhancement (fixed)

output from yat.m4 is ugly

Reported by: Peter Owned by: Peter
Priority: trivial Milestone: yat 0.5
Component: build Version: trunk
Keywords: Cc:

Description

For example I get

checking if version of yat is at least 0.5... configure: WARNING: '/usr/local/bin/yat-config --version' returned 0.5pre, but the minimum
required version is 0.5."
no

which could be prettier. I think we should turn of the warnings. Instead we could collect them in some variable $yat_warnings. Then it is up to the caller to display the warnings in a good place.

Change History (1)

comment:1 Changed 12 years ago by Peter

Resolution: fixed
Status: newclosed

(In [1781]) I moved the warnings not to occur inside a AC_MSG_CHECKING ... AC_MSG_RESULT

I keep the warnings though because I don't know how to hold newlines in shell variable in a safe way, and as the warnings are quite long they wouldn't be pretty as one-liners.

We could add, if it is desired, a mechanism to turn off the warnings, e.g., a macro YAT_NO_WARNINGS that simply sets a variable ac_yat_warning="no" and then modify the output accordingly.

closes #487

Note: See TracTickets for help on using tickets.