Opened 12 years ago

Closed 12 years ago

#528 closed defect (fixed)

make check fails in 0.5-stable branch

Reported by: Jari Häkkinen Owned by: Jari Häkkinen
Priority: major Milestone: yat 0.5.3
Component: test Version: 0.5.2
Keywords: Cc:

Description

... snip ...
PASS: vector_test
PASS: version_test
PASS: view_test
FAIL: documentation_test.sh
================================
1 of 48 tests failed

Verbose ./test/documentation_test.sh -v

/Users/jari/projects/yat-0.5.x/yat/classifier/EnsembleBuilder.h:134 Warning: no matching class member found for
  template < C, D >
  theplu::yat::classifier::EnsembleBuilder< C, D >::EnsembleBuilder(const C &sc, const D &data, const Sampler &sampler)
Possible candidates:
  theplu::yat::classifier::EnsembleBuilder< Classifier, Data >::EnsembleBuilder(const Classifier &, const Data &, const Sampler &)
  theplu::yat::classifier::EnsembleBuilder< Classifier, Data >::EnsembleBuilder(const Classifier &, const Data &, const Sampler &, FeatureSelector &)
  theplu::yat::classifier::EnsembleBuilder< Classifier, Data >::EnsembleBuilder(const EnsembleBuilder &)
/Users/jari/projects/yat-0.5.x/yat/classifier/EnsembleBuilder.h:144 Warning: no matching class member found for
  template < C, D >
  theplu::yat::classifier::EnsembleBuilder< C, D >::EnsembleBuilder(const C &sc, const D &data, const Sampler &sampler, FeatureSelector &fs)
Possible candidates:
  theplu::yat::classifier::EnsembleBuilder< Classifier, Data >::EnsembleBuilder(const Classifier &, const Data &, const Sampler &)
  theplu::yat::classifier::EnsembleBuilder< Classifier, Data >::EnsembleBuilder(const Classifier &, const Data &, const Sampler &, FeatureSelector &)
  theplu::yat::classifier::EnsembleBuilder< Classifier, Data >::EnsembleBuilder(const EnsembleBuilder &)
/Users/jari/projects/yat-0.5.x/yat/classifier/EnsembleBuilder.h:181 Warning: no uniquely matching class member found for
  template < C, D >
  void theplu::yat::classifier::EnsembleBuilder< C, D >::predict(const D &data, std::vector< std::vector< statistics::Averager > > &result)
Possible candidates:
  void theplu::yat::classifier::EnsembleBuilder< Classifier, Data >::predict(const Data &data, std::vector< std::vector< statistics::Averager > > &) at line 109 of file /Users/jari/projects/yat-0.5.x/yat/classifier/EnsembleBuilder.h

Change History (3)

comment:1 Changed 12 years ago by Peter

I cannot reproduce this with doxygen 1.5.6. I suppose you have newer doxygen that is more strict about syntax.

Can you please try replace 'C' and 'D' with 'Classifier' and 'Data', respectively, in the implementation part of EnsembleBuilder.h.

comment:2 in reply to:  1 Changed 12 years ago by Jari Häkkinen

Status: newassigned

Replying to peter:

I cannot reproduce this with doxygen 1.5.6. I suppose you have newer doxygen that is more strict about syntax.

Can you please try replace 'C' and 'D' with 'Classifier' and 'Data', respectively, in the implementation part of EnsembleBuilder.h.

Jepp, that fixes it. I am using doxygen 1.5.8

comment:3 Changed 12 years ago by Jari Häkkinen

Resolution: fixed
Status: assignedclosed

(In [1908]) Fixes #528

Note: See TracTickets for help on using tickets.