Opened 11 years ago

Closed 11 years ago

#574 closed enhancement (fixed)

avoid conflict in NEWS when merging patch release into trunk

Reported by: Peter Owned by: Peter
Priority: trivial Milestone: yat 0.6
Component: build Version: trunk
Keywords: Cc:

Description

The current NEWS file format and ReleaseProcedure create a conflict when merging the patch release into trunk. I think this can be avoided.

The problem is, for example, at release time of 0.5.5 we want to merge the diff between 0.5.5 and 0.5.4

...
See the end of this file for copyrights and conditions. 

+Version 0.5.5 (released 5 November 2009)
+
+  - some text bout 0.5.5
+
Version 0.5.4 (released 12 June 2009)
...

into trunk.

Likewise the diff between trunk and 0.5.4 is

...
See the end of this file for copyrights and conditions. 

+Version 0.6 (released NOT YET)
+
+  - some text about 0.6
+
Version 0.5.4 (released 12 June 2009)
...

The problem is clearly that these diffs overlap and it is impossible to align the diffs together in a uniquely way.

We need to help the algorithm a bit by separating the diffs so they don't overlap, in other words, we need to add a line that should occur below the latter diff and above the former diff. Say, for example, that we add a line with '##', then we get the diffs

...
See the end of this file for copyrights and conditions. 

##

+Version 0.5.5 (released 5 November 2009)
+
+  - some text bout 0.5.5
+
Version 0.5.4 (released 12 June 2009)
...

and

...
See the end of this file for copyrights and conditions. 

+Version 0.6 (released NOT YET)
+
+  - some text about 0.6
+
##

Version 0.5.4 (released 12 June 2009)
...

Note that there is no ## above Version 0.6 because that would give back similar problem that we already have. Instead the line (##) should be added just before branching out a stable-branch from the trunk.

What is a good content for this line?

'##' would make it, but... perhaps a more informative line is more desirable? Any thoughts on this? We could, for example, have something like

yat 0.5.x series created from http://dev.thep.lu.se/yat/svn/branches/0.5-stable

Change History (2)

comment:1 Changed 11 years ago by Jari Häkkinen

The idea is nice. And what is a good content for the '##' line? I think the one you suggest would do it but without word 'created'.

comment:2 Changed 11 years ago by Peter

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.