Opened 8 years ago

Closed 8 years ago

#724 closed defect (fixed)

regression in NeedlemanWunsch

Reported by: Peter Owned by: Peter
Priority: critical Milestone: yat 0.9.1
Component: utility Version: 0.9
Keywords: Cc:

Description

Comparing speclust output using yat 0.8.2 and yat 0.9 I noticed a change in the output. Specifically comparing aligning the last two peaksets in data there are three pairs that should align well at ~852, ~1192, and ~1457. With a sigma = 1.0 they should give erf scores ~= 0.52, 0.99, 0.97 so the NW score should at least be 2.48 since we don't penalize gaps in speclust. With yat 0.9 I get 2e-308 (virtually zero) while with yat 0.8.2 I get 2.50.

Change History (4)

comment:1 Changed 8 years ago by Peter

Status: newassigned

related to ticket #706

comment:2 Changed 8 years ago by Peter

(In [2845]) Extend test for NeedlemanWunsch? and check alignment score between peaksets. refs #724

comment:3 Changed 8 years ago by Peter

(In [2846]) Merged r2845 into 0.9.x branch and marked alignment.test as XFAIL. refs #724.

comment:4 Changed 8 years ago by Peter

Resolution: fixed
Status: assignedclosed

(In [2847]) Fixes #724. Adding another test for NeedlemanWunsch?. Fix bug in NW that score matrix was initialized with smallest positive double rather than smallest negative value. Also fixed an index error in underlying Aligner class causing the mess reported in #724.

Note: See TracTickets for help on using tickets.