Opened 14 years ago

Closed 14 years ago

#81 closed request (fixed)

Make the regression classes uniform

Reported by: Jari Häkkinen Owned by: Peter
Priority: major Milestone: yat 0.2
Component: regression Version: trunk
Keywords: Cc:

Description (last modified by Peter)

Fix the following tickets: #158 #159 #160 #161 #165 #166

Change History (11)

comment:1 Changed 14 years ago by Peter

Description: modified (diff)
Type: defectrequest

comment:2 Changed 14 years ago by Peter

Description: modified (diff)

comment:3 Changed 14 years ago by Peter

(In [698]) changed variable msd to mse. refs #81

comment:4 Changed 14 years ago by Peter

Description: modified (diff)

comment:5 Changed 14 years ago by Peter

Description: modified (diff)

comment:6 Changed 14 years ago by Peter

(In [702]) Refs #81 moved mse_ to inherited classes and made mse() pure virtual because mse is calculated different for different classes and therefore this design is more logic. Fixed docs and other things...

comment:7 Changed 14 years ago by Jari Häkkinen

Milestone: Regression redesign0.2

Milestone Regression redesign deleted

comment:8 Changed 14 years ago by Peter

Component: classifierregression

comment:9 Changed 14 years ago by Peter

(In [713]) Fixes #77, #78, #158, and #163, and refs #81

comment:10 Changed 14 years ago by Peter

(In [729]) Fixes #159. Also removed some inlines in OneDimensionalWeighted? by adding source file. Refs #81

comment:11 Changed 14 years ago by Peter

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.