Opened 22 months ago

Closed 2 weeks ago

#851 closed defect (fixed)

includes are not stripped correctly (sometimes)

Reported by: peter Owned by: peter
Priority: trivial Milestone: yat 0.15
Component: documentation Version: 0.13
Keywords: Cc:

Description

From email with Jari:

The problem is that in doxygen.config.in @abs_top_srcdir@ is used to strip the prefix of the path.

When I manually fix the documentation, I do cd tmp/pristine, which means that @abs_top_srcdir@ is /home/william/jari/tmp/pristine/yat-0.13.x while doxygen reads it as /scratch/bob/jari/tmp/pristine/yat-0.13.x. This is not a problem when cron is run as it does "correct" cd.

Not sure if fixing this is worth the effort? A possible solution is to use pwd -P because then symbolic links are skiped (ie phycisal path is showed). Another possibility is to get doxygen to behave correctly and not choose the physical path (as autotools does).

Change History (2)

comment:1 Changed 2 weeks ago by peter

  • Milestone changed from yat 0.x+ to yat 0.15
  • Status changed from new to assigned

comment:2 Changed 2 weeks ago by peter

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [3690]) fixes #851

Note: See TracTickets for help on using tickets.