Opened 4 years ago

Closed 4 years ago

#863 closed defect (fixed)

boost thread not detected

Reported by: Peter Owned by: Peter
Priority: critical Milestone: yat 0.13.1
Component: build Version: 0.13
Keywords: Cc:

Description

Detection of boost thread fails with output

checking for boostlib >= 1.35... yes
checking whether the Boost::Thread library is available... yes
checking for exit in -lboost_thread... no
checking for exit in -lboost_thread... (cached) no
checking for exit in -lboost_thread... (cached) no
configure: error: Could not link against boost_thread !

the relevant part of the log says:

configure:19516: checking whether the Boost::Thread library is available
configure:19548: g++ -c -pthread  -I/software/htslib/htslib-1.3/include -I/software/gsl/gsl-1.16/include -I/software/boost/boost-1.59.0/include conftest.cpp >&5
configure:19548: $? = 0
configure:19563: result: yes
configure:19592: checking for exit in -lboost_thread
configure:19617: g++ -o conftest  -I/software/htslib/htslib-1.3/include -I/software/gsl/gsl-1.16/include -I/software/boost/boost-1.59.0/include -L/software/htslib/htslib-1.3/lib -L/software/gsl/gsl-1.16/lib -L/software/boost/boost-1.59.0/lib conftest.cpp -lboost_thread  -lgsl -lcblas -lm  >&5
/usr/bin/ld: warning: libboost_system.so.1.59.0, needed by /software/boost/boost-1.59.0/lib/libboost_thread.so, not found (try using -rpath or -rpath-link)
/software/boost/boost-1.59.0/lib/libboost_thread.so: undefined reference to `boost::system::system_category()'
/software/boost/boost-1.59.0/lib/libboost_thread.so: undefined reference to `boost::system::generic_category()'
collect2: error: ld returned 1 exit status

It looks like the problem is that the linker does not find libboost_system although we do indeed provide -L/software/boost/boost-1.59.0/lib. Perhaps because this location is outside the runtime path(?).

Change History (2)

comment:1 Changed 4 years ago by Peter

Owner: changed from Jari Häkkinen to Peter
Status: newassigned

comment:2 Changed 4 years ago by Peter

Resolution: fixed
Status: assignedclosed

(In [3504]) fixes #863. add libboost_system before looking for boost_thread.

Note: See TracTickets for help on using tickets.