Changeset 6763


Ignore:
Timestamp:
Mar 9, 2015, 9:13:04 AM (7 years ago)
Author:
Nicklas Nordborg
Message:

References #1924: Test BASE with Java 8

Updated documentation to recommend Java 8.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/doc/src/docbook/admin/installation.xml

    r6684 r6763  
    5151        This section list some important information that may or may not
    5252        apply when upgrading from the <emphasis>previous</emphasis> BASE
    53         release to the current release (eg. 3.3 to 3.4). If you are
    54         upgrading from a BASE installation that is older (3.0-3.2)
     53        release to the current release (eg. 3.4 to 3.5). If you are
     54        upgrading from a BASE installation that is older (3.0-3.3)
    5555        you should also read <xref linkend="appendix.update_warnings" />.
    5656      </para>
    5757     
    58       <bridgehead>Updating from BASE 2.17 is no longer possible</bridgehead>
     58      <bridgehead>Consider updating to Java 8</bridgehead>
    5959      <para>
    60         If you are still running an BASE 2.17 (or earlier) BASE version
    61         and want to update to BASE 3.4 you must first update to BASE 3.3
    62         or earlier.
     60        Oracle is no longer supporting Java 1.7. We are recommending Java 8
     61        for running BASE. Java 7 is still supported, but will be removed
     62        in the next version (BASE 3.6).
    6363      </para>
    6464     
    65       <bridgehead>PostgreSQL users should change db.dialect</bridgehead>
    66       <para>
    67         In <filename>base.config</filename> there is a <constant>db.config</constant>
    68         setting. Servers running with PostgreSQL as the database should change the
    69         dialect to <classname>org.hibernate.dialect.PostgreSQL9Dialect</classname>
    70         since the <classname>org.hibernate.dialect.PostgreSQLDialect</classname> has
    71         been deprecated.
    72       </para>
    73 
    7465    </important>
    7566   
     
    256247        <listitem>
    257248          <para>
    258             Download and install Java SE 7, available from
     249            Download and install Java SE 8, available from
    259250            <ulink url="http://www.oracle.com/technetwork/java/javase/downloads/index.html" />.
    260251            You can select either the JDK or the JRE version.
    261252          </para>
    262253         
    263           <important>
    264             <para>
    265             As of BASE 3.3 Java SE 7 is required. BASE will no longer run on
    266             Java SE 6 or lower.
    267             </para>
    268           </important>
     254          <note>
     255            <para>
     256            As of BASE 3.5 Java SE 8 is recommended. Support for Java SE 7
     257            will be dropped in BASE 3.6. Java SE 6 or lower is not supported.
     258            </para>
     259          </note>
    269260
    270261        </listitem>
     
    291282                <para>
    292283                  Download and install MySQL (tested with version
    293                   5.1), available from
     284                  5.5), available from
    294285                  <ulink url="http://www.mysql.com/" />. You need to
    295286                  be able to connect to the server over TCP, so
     
    309300              <listitem>
    310301                <para>
    311                   PostgreSQL 9.1 seems to be working very well with
     302                  PostgreSQL 9.3 seems to be working very well with
    312303                  BASE and Hibernate. Download and install PostgreSQL,
    313304                  available from
Note: See TracChangeset for help on using the changeset viewer.