Ignore:
Timestamp:
Apr 15, 2015, 1:01:57 PM (7 years ago)
Author:
Nicklas Nordborg
Message:

References #1926: Switch to Java 8

Updated installation documentation.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/doc/src/docbook/admin/installation.xml

    r6807 r6862  
    4747
    4848    <important id="installation.upgrade.important">
    49       <title>Important information for upgrading to BASE 3.5</title>
     49      <title>Important information for upgrading to BASE 3.6</title>
    5050      <para>
    5151        This section list some important information that may or may not
    5252        apply when upgrading from the <emphasis>previous</emphasis> BASE
    53         release to the current release (eg. 3.4 to 3.5). If you are
    54         upgrading from a BASE installation that is older (3.0-3.3)
     53        release to the current release (eg. 3.5 to 3.6). If you are
     54        upgrading from a BASE installation that is older (3.0-3.4)
    5555        you should also read <xref linkend="appendix.update_warnings" />.
    5656      </para>
    5757     
    58       <bridgehead>Biomaterial lists have been replaced with item lists</bridgehead>
     58      <bridgehead>Update to Java 8</bridgehead>
    5959      <para>
    60         This is a major change that has caused a binary compatibility in the BASE core
    61         API. If you depend on custom extensions or plug-ins that use the biomaterial list
    62         API this code must be updated before updating to BASE 3.5. Read more
    63         about the incompatibilities in <xref linkend="appendix.incompatible.itemlists" />.
     60        BASE will no longer run with Java 7. Unless you have already
     61        updated to Java 8 you should do so before updating to BASE 3.6.
     62        Note that BASE 3.5 also works with both Java 7 and 8 so the Java
     63        update can be made ahead of time.
    6464      </para>
    65      
    66       <bridgehead>Consider updating to Java 8</bridgehead>
    67       <para>
    68         Oracle is no longer supporting Java 1.7. We are recommending Java 8
    69         for running BASE. Java 7 is still supported, but will be removed
    70         in the next version (BASE 3.6).
    71       </para>
    72      
    73       <bridgehead>Consider updating to Tomcat 8</bridgehead>
    74       <para>
    75         We have now tested BASE with Tomcat 8 and it seems to work without
    76         any problems. Support for Tomcat 7 will be removed in the next
    77         version (BASE 3.6).
    78       </para>
    79      
    80      
     65   
    8166    </important>
    8267   
     
    270255          <note>
    271256            <para>
    272             As of BASE 3.5 Java SE 8 is recommended. Support for Java SE 7
    273             will be dropped in BASE 3.6. Java SE 6 or lower is not supported.
     257            As of BASE 3.6 only Java SE 8 is supported. Java SE 7
     258            or lower is not supported.
    274259            </para>
    275260          </note>
Note: See TracChangeset for help on using the changeset viewer.