Ignore:
Timestamp:
May 21, 2019, 8:47:30 AM (2 years ago)
Author:
Nicklas Nordborg
Message:

References #2139: Switch to Java 11 (or later)

Changed build script to specify Java 11. Biggest change is that the 'source' and 'target' parameters have merged to 'release' parameter and that 'bootclasspath' is no longer supported when compiling against java versions > 8.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/config/dist/web.xml

    r7635 r7711  
    225225  <!-- Our JSP:s will not compile unless:   -->
    226226  <!-- strictQuoteEscaping=false (default is true)-->
    227   <!-- compilerSourceVM=1.8 (default is 1.7) -->
    228   <!-- compilerTargetVM=1.8 (default is 1.7) -->
     227  <!-- compilerSourceVM=11 (default is 1.8) -->
     228  <!-- compilerTargetVM=11 (default is 1.8) -->
    229229  <servlet>
    230230    <servlet-name>jsp</servlet-name>
     
    236236    <init-param>
    237237      <param-name>compilerSourceVM</param-name>
    238       <param-value>1.8</param-value>
     238      <param-value>11</param-value>
    239239    </init-param>
    240240    <init-param>
    241241      <param-name>compilerTargetVM</param-name>
    242       <param-value>1.8</param-value>
     242      <param-value>11</param-value>
    243243    </init-param>
    244244    <init-param>
Note: See TracChangeset for help on using the changeset viewer.