Changeset 7826


Ignore:
Timestamp:
Jun 9, 2020, 1:43:11 PM (16 months ago)
Author:
Nicklas Nordborg
Message:

References #2214: Upgrade Hibernate and other 3-rd party components

Added a note about testing is only made with MySQL to the update section.

Location:
trunk/doc/src/docbook
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/doc/src/docbook/admin/installation.xml

    r7731 r7826  
    4747
    4848    <important id="installation.upgrade.important">
    49       <title>Important information for upgrading to BASE 3.16</title>
     49      <title>Important information for upgrading to BASE 3.17</title>
    5050      <para>
    5151        This section list some important information that may or may not
    5252        apply when upgrading from the <emphasis>previous</emphasis> BASE
    53         release to the current release (eg. 3.15 to 3.16). If you are
    54         upgrading from a BASE installation that is older (3.0-3.14)
     53        release to the current release (eg. 3.16 to 3.17). If you are
     54        upgrading from a BASE installation that is older (3.0-3.15)
    5555        you should also read <xref linkend="appendix.update_warnings" />.
    5656      </para>
    5757     
    58       <bridgehead>Java 11 or later is now required (OpenJDK)</bridgehead>
     58      <bridgehead>MySQL versions before 8.0 are no longer supported</bridgehead>
    5959      <para>
    60         Starting with this release, Java 11 is required for running BASE.
    61         BASE 3.15 was the last BASE version with support for Java 8.
    62         Note that Oracle no longer provide a free JDK or JRE.
    63         Instead, OpenJDK has to be used, which can be downloaded from
    64         <ulink url="https://openjdk.java.net/" />
    65       </para>
    66    
    67       <bridgehead>Tomcat 8 and PostgreSQL 9 are no longer supported</bridgehead>
    68       <para>
    69         Starting with this release, we no longer test BASE with Tomcat 8
    70         or PostgreSQL 9. Thus, we are recommening that existing installations
    71         are upgraded to at least Tomcat 9 and PostgreSQL 11.
     60        Starting with this release, we no longer test BASE with MySQL versions
     61        before 8.0. We are recommending existing installations are upgraded to
     62        use MySQL 8 or migrated to PostgreSQL.
    7263      </para>
    7364   
     
    304295              <listitem>
    305296                <para>
    306                   Download and install MySQL (tested with version
    307                   5.5), available from
     297                  As of BASE 3.17 we are only testing with MySQL 8.0.
     298                  Other versions may also work, but are no longer tested.
     299                  Download MySQL from
    308300                  <ulink url="http://www.mysql.com/" />. You need to
    309301                  be able to connect to the server over TCP, so
  • trunk/doc/src/docbook/appendix/update_warnings.xml

    r7731 r7826  
    3535    to the current version.
    3636  </para>
     37
     38  <sect1 id="appendix.update_warnings.3.17">
     39    <title>BASE 3.17</title>
     40 
     41    <bridgehead>MySQL versions before 8.0 are no longer supported</bridgehead>
     42    <para>
     43      Starting with this release, we no longer test BASE with MySQL versions
     44      before 8.0. We are recommending existing installations are upgraded to
     45      use MySQL 8 or migrated to PostgreSQL.
     46    </para>
     47   
     48  </sect1>
     49
    3750 
    3851  <sect1 id="appendix.update_warnings.3.16">
Note: See TracChangeset for help on using the changeset viewer.