Opened 13 years ago

Closed 13 years ago

#1112 closed enhancement (fixed)

Create new items with project default properties from active project

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.9
Component: core Version:
Keywords: Cc:

Description

When creating new items and a project that has project defaults is active the project default properties should be set on the new items.

Change History (10)

comment:1 Changed 13 years ago by Nicklas Nordborg

Milestone: BASE 2.9

comment:2 Changed 13 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:3 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4527]) Fixes #1112: Create new items with project default properties from active project

comment:4 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: closedreopened

See #1123.

comment:5 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: reopenedclosed

(In [4533]) Fixes #1112: Create new items with project default properties from active project

Changed permission checked so that the active project and logged in user is always readable by plug-ins.

comment:6 Changed 13 years ago by Nicklas Nordborg

(In [4646]) References #1112: Create new items with project default properties from active project

Delete the protocol instead of the sample.

comment:7 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: closedreopened

There is a serious bug in the fix for this that causes all users to get read access to everything. The problem is related to the lines in [4533] that contains:

pp.granted |= Permission.grant(Permission.READ)

This may seem harmless but actually changes the value of the PluginPermission?.NO_PLUGIN which should never change... The root cause is of course the bad design in PluginPermission? class which exposes the internal variables. It may make sense to have them readable, but they should at least be "final".

comment:8 Changed 13 years ago by Nicklas Nordborg

Status: reopenednew

comment:9 Changed 13 years ago by Nicklas Nordborg

Status: newassigned

comment:10 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4649]) Fixes #1112: Create new items with project default properties from active project

Note: See TracTickets for help on using tickets.