Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1137 closed enhancement (fixed)

Importing hybridizations fail when association is tried to a slide that already has a hyb associated

Reported by: Jari Häkkinen Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.8.3
Component: coreplugins Version: 2.8.2
Keywords: Cc:

Description

Hybs and slides have a 1-to-1 relation so the problem is expected. However, the error reported back from the importer plug-in is somewhat hard to understand. The hybridization importer should not import hybridization that trying to link to a slide that is already occupied and report this issue in a more user friendly way. I suppose this needs to be treated with the nice error options set, i.e., option skip hybs that tries to connect to an occupied slide. Maybe this is already covered by the error treatment option but it is not easy to see which option it could be.

Change History (3)

comment:1 Changed 13 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4574]) Fixes #1137: Importing hybridizations fail when association is tried to a slide that already has a hyb associated

comment:3 Changed 13 years ago by Nicklas Nordborg

My first approach was to simple filter away array slides that had already been used. It worked well when creating new hybridizations, but not when updating existing hybridizations since it would not find the already attached array slide and would reset the link to null (or throw an ItemNotFoundException?).

So, all I have done is to change the error message to something more user friendly and understandable. There are no error handling options that can be used to ignore the error message. The input file has to be edited so that only non-used array slides are referenced. Error handling options will be added in 2.9. See #1142.

Note: See TracTickets for help on using tickets.