Opened 13 years ago

Closed 13 years ago

#1150 closed defect (fixed)

Incorrect mapping of BASE1/BASE2 differences by Base1PluginExecuter

Reported by: Nicklas Nordborg Owned by: Jari Häkkinen
Priority: major Milestone: BASE 2.8.4
Component: coreplugins Version:
Keywords: Cc:

Description

As an example if a BASE1-plugin asks for 'geneSymbol' the generated BASEFile has a 'symbol' column.

The root cause of the problem seems to be the hardcoded mappings in Base1PluginExecuter.loadNameMap() method. All BASE1/BASE2 differences should use formulas. But because of the way the hardcoded mappings are implemented they override any formulas with the same name. Eg. The hardcoded mapping for 'geneSymbol' is used even if there is a formula for 'geneSymbol'.

Change History (4)

comment:1 Changed 13 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 13 years ago by Nicklas Nordborg

(In [4592]) References #1150: Incorrect mapping of BASE1/BASE2 differences by Base1PluginExecuter

Tested and works with the test programs. Should be tested with more BASE1 plug-ins.

comment:3 Changed 13 years ago by Nicklas Nordborg

Owner: changed from Nicklas Nordborg to Jari Häkkinen
Status: assignednew

comment:4 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [4593]) Fixes #1150: Incorrect mapping of BASE1/BASE2 differences by Base1PluginExecuter

Added missing functions, pos() and rep('id'), to the expression builder.

Note: See TracTickets for help on using tickets.