Opened 13 years ago

Closed 13 years ago

#1151 closed task (fixed)

Create a batch-importer version of the 'roles' test procedure

Reported by: Nicklas Nordborg Owned by: Martin Svensson
Priority: minor Milestone: BASE 2.9
Component: test Version:
Keywords: Cc:

Description

The 'roles' test program is already

  1. A manual test procedure to test the web client
  2. A programmed test procedure to test the core and permission system

It could be useful to extend the test procedure to use the various batch importers instead of using hard-coded values in the test program code. Some parts doesn't have batch importers. It would be preferable if the new variant could re-use the existing code for creating user, groups, projects, software, hardware, protocols, etc.

Batch importers to test: biosource, sample, extract, labeled extract, array design, array batch, array slide, hybridization, scan, raw bioassay and raw data.

Change History (8)

comment:1 Changed 13 years ago by Martin Svensson

Owner: changed from everyone to Martin Svensson
Status: newassigned

comment:2 Changed 13 years ago by Martin Svensson

(In [4625]) References #1151 Created new classes which do the power user-role test and user-role test with batch importers. The new functionallity is not tested yet.

comment:3 Changed 13 years ago by Martin Svensson

(In [4628]) References #1151 Refactored to better use the existing code in the roles test. There is a risk the changes can effect the existing test program, this is not yet checked.

comment:4 Changed 13 years ago by Martin Svensson

Resolution: fixed
Status: assignedclosed

(In [4633]) Fixes #1151 User role-test can now test batch importers. Documentation is updated(still in old format). Also updated build.xml to copy the test/role-directory when creating dist, links from wiki will work after next release.

comment:5 Changed 13 years ago by Nicklas Nordborg

(In [4640]) References #1151: Create a batch-importer version of the 'roles' test procedure

Remove unused import.

comment:6 Changed 13 years ago by Nicklas Nordborg

(In [4655]) References #1145 and #1151.

Added instructions in the documentation for using the batch importer as an alternative to manual import for each raw data set.

comment:7 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: closedreopened

The 'rawbioassay_out.txt' file is missing in the repository. Running the 'roles' test program reports:

...
--Uploading file: /batchimport/rawbioassay_out.txt
--NOT FOUND - skipping upload
...

and later fails with:

--Executing job: Batch import of raw bioassays to Project A
net.sf.basedb.core.BaseException: File 'rawbioassay_out.txt' doesn't match the expected file format.
  at net.sf.basedb.test.PluginUtil.executeJob(PluginUtil.java:148)
  at net.sf.basedb.test.roles.UserTest.importRawBioAssays(UserTest.java:547)
  at net.sf.basedb.test.roles.UserTest.run(UserTest.java:256)
  at net.sf.basedb.test.roles.Run.main(Run.java:70)
Caused by: net.sf.basedb.core.UnsupportedFileFormatException: File 'rawbioassay_out.txt' doesn't match the expected file format.
  at net.sf.basedb.plugins.AbstractFlatFileImporter.run(AbstractFlatFileImporter.java:464)
  at net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:106)     
  at net.sf.basedb.test.PluginUtil.executeJob(PluginUtil.java:145)
  ... 3 more
++Leaving user test (FAILED)

comment:8 Changed 13 years ago by Martin Svensson

Resolution: fixed
Status: reopenedclosed

The file has been added to the test-data repository.

Note: See TracTickets for help on using tickets.