Opened 13 years ago

Closed 13 years ago

#1161 closed enhancement (fixed)

Improve error handling in the extension system

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.9
Component: core Version:
Keywords: Cc:

Description

The problem is that while an extension may be successfully installed it may not run as expected due to some problem with the implementation. An example is when the configuration file is missing for the FTP server extension (see http://baseplugins.thep.lu.se/ticket/128). The FTP server reports this by throwing an exception (from the ServiceControllerAction?.start() method). The extension system catches the exception (in the ExtensionsInvoker?.render() methods) and writes the stack trace to the log file and then continues as if nothing has happened. There is no place except for the log file where it is possible to get any information about this error.

It would be useful to have this information available in the web interface as well. For example, when working on the Administrate -> Services page it would be nice to have the error message on that page. It would also be useful to have the error message on the Extensions -> Installed extensions page.

I think we should keep this information somewhere in the Registry. We have to make sure that no thread-issues arises from this since all requests uses the same registry.

Change History (2)

comment:1 Changed 13 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4618]) Fixes #1161: Improve error handling in the extension system

Note: See TracTickets for help on using tickets.