Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1162 closed defect (fixed)

Raw bioassay importer fails with InvalidUseOfNullException when raw data type is not found

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: trivial Milestone: BASE 2.9
Component: coreplugins Version:
Keywords: Cc:

Description

The error message should be an ItemNotFoundException? instead so users know what is causing it.

net.sf.basedb.core.BaseException: Invalid use of null. The 'rawDataType must be specified for platform: Generic' value cannot be set to null. on line 2: 1590818011 1 "Ge...
at net.sf.basedb.plugins.AbstractFlatFileImporter.doImport(AbstractFlatFileImporter.java:638)
at net.sf.basedb.plugins.AbstractFlatFileImporter.run(AbstractFlatFileImporter.java:443)
at net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:108)
at net.sf.basedb.core.InternalJobQueue$JobRunner.run(InternalJobQueue.java:506)
at java.lang.Thread.run(Thread.java:619)
Caused by: net.sf.basedb.core.InvalidUseOfNullException: Invalid use of null. The 'rawDataType must be specified for platform: Generic' value cannot be set to null.
at net.sf.basedb.core.RawBioAssay.setPlatform(RawBioAssay.java:475)
at net.sf.basedb.core.RawBioAssay.getNew(RawBioAssay.java:148)
at net.sf.basedb.plugins.batchimport.RawBioAssayImporter.createItem(RawBioAssayImporter.java:338)
at net.sf.basedb.plugins.batchimport.RawBioAssayImporter.createItem(RawBioAssayImporter.java:62)
at net.sf.basedb.plugins.batchimport.AbstractItemImporter.handleData(AbstractItemImporter.java:625)
at net.sf.basedb.plugins.AbstractFlatFileImporter.doImport(AbstractFlatFileImporter.java:608)
... 4 more

Change History (3)

comment:1 Changed 13 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4622]) Fixes #1162: Raw bioassay importer fails with InvalidUseOfNullException? when raw data type is not found

comment:3 Changed 13 years ago by Nicklas Nordborg

(In [4629]) References #1162: Raw bioassay importer fails with InvalidUseOfNullException? when raw data type is not found

The last fix ([4622]) created a problem with file-only platforms that has an implicit raw data type.

Note: See TracTickets for help on using tickets.