Opened 13 years ago

Closed 13 years ago

#1298 closed defect (invalid)

error when hybridising multiple arrays on one slide (Agilent 4x44k)

Reported by: base Owned by: everyone
Priority: major Milestone:
Component: web Version:
Keywords: Cc: klemens.vierlinger@…

Description

I am using the agilent 4x44k arrays (4 arrays per slide), and cant seem to be able to enter hybridisations. This is what I do:

  • I have array designs with 4 arrays per slide and I have a batch with 20 slides of that design
  • I create a new hybridisation whereby I enter '4' Arrays and pick 'slideXY' on the 'hybridisation' tab, and array index:'1' on the 'labeled extracts' tab.
  • So far so good, but if I want to hybridise a new sample on the same slide (I do the same as above but use array index: 2) I get the error message below:

Best Klemens

Version BASE 2.9.3 (build #4774; schema #65) Web server Apache Tomcat/6.0.18 Database Server MySQL 5.0.45-Max Database Dialect org.hibernate.dialect.MySQLInnoDBDialect JDBC Driver com.mysql.jdbc.Driver (version 5.1) Java runtime Java(TM) SE Runtime Environment (1.6.0_12-b04), Sun Microsystems Inc. Operating system Linux amd64 2.6.22.19-0.2-default Memory Total: 135.6 MB Free: 10.5 MB Max: 444.5 MB Browser Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 Error message Duplicate entry '102' for key 2 Stack trace

DatabaseException? ...at HibernateUtil?.saveData(HibernateUtil?.java:1134) ...at DbControl?.commit(DbControl?.java:394) ...at org.apache.jsp.views.hybridizations.index_jsp._jspService(index_jsp.java:238) ...at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:70) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:717) ...at org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.java:374) ...at org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:342) ...at org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:267)

...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:717) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:290) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:206) ...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(CharacterEncodingFilter?.java:70) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:235) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:206) ...at org.apache.catalina.core.StandardWrapperValve?.invoke(StandardWrapperValve?.java:233) ...at org.apache.catalina.core.StandardContextValve?.invoke(StandardContextValve?.java:191) ...at org.apache.catalina.core.StandardHostValve?.invoke(StandardHostValve?.java:128) ...at org.apache.catalina.valves.ErrorReportValve?.invoke(ErrorReportValve?.java:102) ...at org.apache.catalina.core.StandardEngineValve?.invoke(StandardEngineValve?.java:109) ...at org.apache.catalina.connector.CoyoteAdapter?.service(CoyoteAdapter?.java:286) ...at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845) ...at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583) ...at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447) ...at java.lang.Thread.run(Thread.java:619)

Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLIntegrityConstraintViolationException: Duplicate entry '102' for key 2 ...at sun.reflect.NativeConstructorAccessorImpl?.newInstance0(Native Method) ...at sun.reflect.NativeConstructorAccessorImpl?.newInstance(NativeConstructorAccessorImpl?.java:39) ...at sun.reflect.DelegatingConstructorAccessorImpl?.newInstance(DelegatingConstructorAccessorImpl?.java:27) ...at java.lang.reflect.Constructor.newInstance(Constructor.java:513) ...at com.mysql.jdbc.Util.handleNewInstance(Util.java:406) ...at com.mysql.jdbc.Util.getInstance(Util.java:381) ...at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1015) ...at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:956) ...at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3491) ...at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3423) ...at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1936) ...at com.mysql.jdbc.ServerPreparedStatement?.serverExecute(ServerPreparedStatement?.java:1328) ...at com.mysql.jdbc.ServerPreparedStatement?.executeInternal(ServerPreparedStatement?.java:838) ...at com.mysql.jdbc.PreparedStatement?.executeUpdate(PreparedStatement?.java:2019) ...at com.mysql.jdbc.PreparedStatement?.executeUpdate(PreparedStatement?.java:1937) ...at com.mysql.jdbc.PreparedStatement?.executeUpdate(PreparedStatement?.java:1922) ...at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement?.executeUpdate(NewProxyPreparedStatement?.java:105) ...at org.hibernate.id.IdentityGenerator?$GetGeneratedKeysDelegate?.executeAndExtract(IdentityGenerator?.java:94) ...at org.hibernate.id.insert.AbstractReturningDelegate?.performInsert(AbstractReturningDelegate?.java:57) ...at org.hibernate.persister.entity.AbstractEntityPersister?.insert(AbstractEntityPersister?.java:2186) ...at org.hibernate.persister.entity.AbstractEntityPersister?.insert(AbstractEntityPersister?.java:2666) ...at org.hibernate.action.EntityIdentityInsertAction?.execute(EntityIdentityInsertAction?.java:71) ...at org.hibernate.engine.ActionQueue?.execute(ActionQueue?.java:279) ...at org.hibernate.event.def.AbstractSaveEventListener?.performSaveOrReplicate(AbstractSaveEventListener?.java:321) ...at org.hibernate.event.def.AbstractSaveEventListener?.performSave(AbstractSaveEventListener?.java:204) ...at org.hibernate.event.def.AbstractSaveEventListener?.saveWithGeneratedId(AbstractSaveEventListener?.java:130) ...at org.hibernate.event.def.DefaultSaveOrUpdateEventListener?.saveWithGeneratedOrRequestedId(DefaultSaveOrUpdateEventListener?.java:210) ...at org.hibernate.event.def.DefaultSaveEventListener?.saveWithGeneratedOrRequestedId(DefaultSaveEventListener?.java:56) ...at org.hibernate.event.def.DefaultSaveOrUpdateEventListener?.entityIsTransient(DefaultSaveOrUpdateEventListener?.java:195) ...at org.hibernate.event.def.DefaultSaveEventListener?.performSaveOrUpdate(DefaultSaveEventListener?.java:50) ...at org.hibernate.event.def.DefaultSaveOrUpdateEventListener?.onSaveOrUpdate(DefaultSaveOrUpdateEventListener?.java:93) ...at org.hibernate.impl.SessionImpl?.fireSave(SessionImpl?.java:562) ...at org.hibernate.impl.SessionImpl?.save(SessionImpl?.java:550) ...at org.hibernate.impl.SessionImpl?.save(SessionImpl?.java:546) ...at HibernateUtil?.saveData(HibernateUtil?.java:1129) ...at DbControl?.commit(DbControl?.java:394) ...at org.apache.jsp.views.hybridizations.index_jsp._jspService(index_jsp.java:238) ...at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:70) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:717) ...at org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.java:374) ...at org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:342) ...at org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:267) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:717) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:290) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:206) ...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(CharacterEncodingFilter?.java:70) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:235) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:206) ...at org.apache.catalina.core.StandardWrapperValve?.invoke(StandardWrapperValve?.java:233) ...at org.apache.catalina.core.StandardContextValve?.invoke(StandardContextValve?.java:191) ...at org.apache.catalina.core.StandardHostValve?.invoke(StandardHostValve?.java:128) ...at org.apache.catalina.valves.ErrorReportValve?.invoke(ErrorReportValve?.java:102) ...at org.apache.catalina.core.StandardEngineValve?.invoke(StandardEngineValve?.java:109) ...at org.apache.catalina.connector.CoyoteAdapter?.service(CoyoteAdapter?.java:286) ...at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845) ...at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583) ...at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447) ...at java.lang.Thread.run(Thread.java:619)

Change History (1)

comment:1 Changed 13 years ago by Nicklas Nordborg

Resolution: invalid
Status: newclosed

A slide can only be associated with a single hybridization. The proper way for this case is to create one hybridization that is linked to the slide and to all (four) labeled extracts, each one with a different index (1-4).

Note: See TracTickets for help on using tickets.