Opened 12 years ago

Closed 12 years ago

#1462 closed enhancement (fixed)

Select plugin+configuration in a single list

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.16
Component: web Version:
Keywords: Cc:

Description

The current dialog for selecting a plug-in + a configuration has two lists. One list for selecting the plug-in and then a second list for selecting a configuration. The second list is updated automatically based on the selection in the first list.

The problem is that it is sometimes difficult to find the correct plug-in. In particular in the analysis part were a lot of plug-ins are listed as configurations for the Base1PluginExecutor.

It may be better to merge the two lists into a single list with an "internal" two-level structure. Eg. plug-ins are listed in the top-level and configurations are listed below but with a slight indentation.

Need to verify that this works properly for all plug-ins depending on if they need and have a configuration or not.

Change History (3)

comment:1 Changed 12 years ago by Nicklas Nordborg

Milestone: BASE 2.16

comment:2 Changed 12 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:3 Changed 12 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [5372]) Fixes #1462: Select plugin+configuration in a single list

Note: See TracTickets for help on using tickets.