Opened 11 years ago

Closed 10 years ago

#1572 closed defect (fixed)

Filtering of rawbioassays when adding to experiment does not work properly

Reported by: base Owned by: Nicklas Nordborg
Priority: critical Milestone: BASE 3.0.2
Component: web Version: 2.16.1
Keywords: filtering active project rawbioassays experiment Cc: pawel.sztromwasser@…

Description

Active project filtering fails in rawbioassay list when adding to experiment. Although rawbioassays are shared to a project they are not shown, so if a user does not own rawbioassays he/she won't be able to add them to an experiment (I havent tested sharing to groups).

Change History (10)

comment:1 Changed 11 years ago by Nicklas Nordborg

I am not able to reproduce this. I can see the raw bioassays just fine. Are you sure that the project the raw bioassays have been shared to is the active project and that no other filter is active?

comment:2 Changed 11 years ago by Nicklas Nordborg

Milestone: BASE 2.16.2
Resolution: worksforme
Status: newclosed

comment:3 Changed 10 years ago by base

Yes I am sure. I just noticed that it also happens in selection of the experimental factors (the same window, another tab). If only 'in the project' is selected, I can't see annotation types shared to the project.

comment:4 Changed 10 years ago by Nicklas Nordborg

I am not able to get the behavior you describe. I think you'll need to find a way to reproduce this with very detailed step-by-step instructions.

comment:5 Changed 10 years ago by base

I know what was the issue. I was not a member nor the owner of the project. I set it active, and was able to see and edit stuff because I have an administrator role, but I was not a part of the project. After I added myself as the member, everything worked as it should have. But than it means that the behaviour of the filter is not entirely consistent between the main list of items and the selection list when editing the experiment.

PS I marked comments/updates to the ticket to be cc'ed to me. They aren't. Is it a higher level setting in Trac that prevents it?

comment:6 Changed 10 years ago by Nicklas Nordborg

Ok, I can verify the same behavior. The 'in current project' option works in the normal listing but not when selecting related items for another item (for example, raw bioassays or annotation types for an experiment).

The problem can also be seen in the normal listing if the 'Permission' column is made visible and 'Use' is selected as a filter. The selection list dialog has an implicit hidden filter for Permission=Use. My guess is that it is the implementation of the permission filter that is the root of the problem.

I also discovered that it is impossible to clear the permission filter once it has been set, but that is another issue (#1656).

Regarding the CC field: I think the Trac server has not been configured to send emails. I'll check with the server admin to see if it is possible to enable this.

comment:7 Changed 10 years ago by Nicklas Nordborg

Milestone: BASE 3.0.2
Resolution: worksforme
Status: closedreopened

comment:8 Changed 10 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: reopenednew

comment:9 Changed 10 years ago by Nicklas Nordborg

Status: newassigned

comment:10 Changed 10 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [5926]) Fixes #1572: Filtering of rawbioassays when adding to experiment does not work properly

The problem was that when the user is not a real member of a project, but administrative permissions makes it possible to set it as the active project, the administrative permissions are 'forgotten' in some cases (eg. when using the permission filter on an item query). This has now been fixed by making sure that the role-based permissions for the project are considered when determining the final permissions.

Note: See TracTickets for help on using tickets.