Opened 10 years ago

Closed 10 years ago

#1622 closed defect (fixed)

Blank page when trying to upload a file if not enough quota

Reported by: Nicklas Nordborg Owned by: everyone
Priority: minor Milestone: BASE 3.0
Component: web Version:
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

Replaces #1619 and #1621.

  1. Create a user account without any quota.
  2. Log in as that user and go to the View->Files page.
  3. Click on 'Upload file'. The popup window is blank.

Tried this on BASE 2.17 with Firefox 4 (Linux) and IE 9 (Windows 7). Tomcat logs the error but that is not very helpful for the user.

Change History (4)

comment:1 Changed 10 years ago by Nicklas Nordborg

Description: modified (diff)

comment:2 Changed 10 years ago by Nicklas Nordborg

Description: modified (diff)

comment:3 Changed 10 years ago by Nicklas Nordborg

It seems like the problem is originating from the fact the the file upload dialog is a frameset that is dived into two frames. One frame that is displaying the gui (file selection, upload progress, etc.) and a hidden frame (size=0) that performs the actual upload. Since most errors has typically come from the upload part, there is an error handler that re-sizes the frames so that the gui frame is hidden and the upload frame is shown.

So, behind the scenes the error message about the missing quota is generated, but it is immediately hidden, and since the upload hasn't started yet everything that remains is an empty window. The fix is to not mess with the frames until the upload has really started.

comment:4 Changed 10 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [5747]) Fixes #1622: Blank page when trying to upload a file if not enough quota

Note: See TracTickets for help on using tickets.