Opened 10 years ago

Closed 10 years ago

#1633 closed defect (fixed)

NumberFormatException when parsing NaN values

Reported by: Nicklas Nordborg Owned by: everyone
Priority: trivial Milestone: BASE 3.0
Component: core Version:
Keywords: Cc:

Description

This was fixed a long time ago by ticket #708 for one case, but not when number formatters are used (#311).

Here is an example exception from the raw data importer:

Caused by: net.sf.basedb.core.BaseException: For input string: "nan" on line 1253 in file 'isoforms.fpkm_tracking': NM_001193599        - -...                                                                                                                                        
        at net.sf.basedb.plugins.AbstractFlatFileImporter.doImport(AbstractFlatFileImporter.java:708)                                      
        at net.sf.basedb.plugins.AbstractFlatFileImporter.run(AbstractFlatFileImporter.java:445)                                           
        at net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:116)                                               
        at net.sf.basedb.test.PluginUtil.executeJob(PluginUtil.java:150)                                                                   
        ... 3 more                                                                                                                         
Caused by: java.lang.NumberFormatException: For input string: "nan"                                                                        
        at net.sf.basedb.core.Type.parseString(Type.java:534)                                                                              
        at net.sf.basedb.core.ExtendedProperty.parseString(ExtendedProperty.java:237)                                                      
        at net.sf.basedb.plugins.RawDataFlatFileImporter.handleData(RawDataFlatFileImporter.java:844)                                      
        at net.sf.basedb.plugins.AbstractFlatFileImporter.doImport(AbstractFlatFileImporter.java:676)                                      
        ... 6 more                                                                                                                        

Change History (1)

comment:1 Changed 10 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [5776]) Fixes #1633: NumberFormatException? when parsing NaN values

Note: See TracTickets for help on using tickets.