Opened 10 years ago

Closed 10 years ago

#1652 closed enhancement (wontfix)

Installing extensions in a subdirectory to `plugindir` is not possible but would be nice

Reported by: Jari Häkkinen Owned by: everyone
Priority: major Milestone:
Component: install Version: 3.0.1
Keywords: Cc:

Description

I usually install plugins in a directory structure below plugindir like

plugindir/net/sf/basedb/plugin1
plugindir/net/sf/basedb/plugin2
plugindir/se/lu/onk/plugin3
plugindir/se/lu/onk/plugin4
...

and I tried the same with an extension. The wizard could not find the extension that I placed in plugindir/net/sf/basedb/extensionname.

Can we make the install wizard to go through the subdirectories in plugindir

Change History (1)

comment:1 Changed 10 years ago by Nicklas Nordborg

Resolution: wontfix
Status: newclosed

This is by design. It has always been like this for extensions and is needed to make sure that JAR filenames are unique.

Last edited 10 years ago by Nicklas Nordborg (previous) (diff)
Note: See TracTickets for help on using tickets.