Opened 7 years ago

Closed 7 years ago

#1808 closed defect (fixed)

Support for comment lines in GTF parser

Reported by: Nicklas Nordborg Owned by: everyone
Priority: major Milestone: BASE 3.3
Component: coreplugins Version:
Keywords: Cc:

Description

GTF importer support was added in #1623 (reporters) and #1624 (array design).

The importers work as long as the file only contains "Field" lines (http://www.ensembl.org/info/website/upload/gff.html). But checking the details of the specification there can be other types of data/comment lines as well.

See also http://www.mail-archive.com/basedb-users@lists.sourceforge.net/msg02133.html for more information.

The problem is with a "pre-parsing" step that converts a GTF file into a regular tab-separated file. The simple solution is to just let the pre-parser pass on everything it doesn't understand without modification.

Change History (1)

comment:1 Changed 7 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [6459]) Fixes #1808: Support for comment lines in GTF parser

Note: See TracTickets for help on using tickets.