Opened 8 years ago

Closed 8 years ago

#1834 closed defect (fixed)

Failed AJAX calls are not forwarded to the registered on-failure handler

Reported by: Nicklas Nordborg Owned by: everyone
Priority: critical Milestone: BASE 3.3.1
Component: web Version:
Keywords: Cc:

Description

An AJAX request can register two callback handlers. One for a successful request and another for a failed request (eg. HTTP status code != 200). The problem is that if the request fails, none of the callback methods are called.

Change History (1)

comment:1 Changed 8 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [6522]) Fixes #1834: Failed AJAX calls are not forwarded to the registered on-failure handler

Note: See TracTickets for help on using tickets.