Opened 16 years ago

Closed 16 years ago

#184 closed task (fixed)

Running SQL/HQL after an update to the database

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: blocker Milestone: BASE 2.0 RC2
Component: install Version:
Keywords: Cc:

Description

When updating the database there must be some way to update the values in newly added columns, ie. add a default value to not-null columns.

For example: Error message exception setting property value with CGLIB (set hibernate.cglib.use_reflection_optimizer=false for more info) setter of net.sf.basedb.core.data.JobData?.setActiveProjectId Stack trace

...at HibernateUtil?.loadList(HibernateUtil?.java:1300) ...at ItemQuery?.list(ItemQuery?.java:93) ...at org.apache.jsp.my_005fbase.index_jsp._jspService(org.apache.jsp.my_005fbase.index_jsp:122) ...at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:97)

.... .... Caused by: java.lang.NullPointerException? ...at data.JobData?$$BulkBeanByCGLIB$$46ea92ef.setPropertyValues() ...at org.hibernate.tuple.PojoEntityTuplizer?.setPropertyValuesWithOptimizer(PojoEntityTuplizer?.java:212)

Change History (2)

comment:1 Changed 16 years ago by Nicklas Nordborg

Status: newassigned

comment:2 Changed 16 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [2142]) Fixes #184: Running SQL/HQL after an update to the database.

Note: See TracTickets for help on using tickets.