Opened 7 years ago

Closed 7 years ago

#1851 closed defect (fixed)

Scale factor rounding causes popup dialog problems

Reported by: Nicklas Nordborg Owned by: everyone
Priority: major Milestone: BASE 3.3.2
Component: web Version:
Keywords: Cc:

Description

The scale factor is used to control sizes of popup windows in case the user's may want larger or smaller dialogs.

The scale is internally stored as a floating point with 1 indicating no change in scale. The problem is that the javascript uses parseInt() to parse out the value from the string meaning that scales below 1 become 0 resulting in BASE trying to open popup windows with width and height equal to 0.

This problem is probably what cause #1841 in the first place.

The workaround is to select a scale factor of at least 100.

Change History (1)

comment:1 Changed 7 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [6543]) Fixes #1851: Scale factor rounding causes popup dialog problems

Also fixed an issue when trying to open dialog that was bigger than screen size. The browser will not let you which is causing a possible large correction factor to be used the next time.

Note: See TracTickets for help on using tickets.