Opened 7 years ago

Closed 7 years ago

#1927 closed task (fixed)

Test BASE with Tomcat 8

Reported by: Nicklas Nordborg Owned by: everyone
Priority: major Milestone: BASE 3.5
Component: install Version:
Keywords: Cc:

Description

Tomcat 8 has been available since early 2014. Even though Tomcat 7 is still being maintained, I think we should move ahead and test if BASE works with Tomcat 8. If all goes well, the recommendation should be to use Tomcat 8 in favor of Tomcat 7 and then we can finalize the move in the next BASE release.

See also #1924 and #1926 which is about switching to Java 8.

Change History (4)

comment:1 Changed 7 years ago by Nicklas Nordborg

(In [6764]) References #1927: Test BASE with Tomcat 8

Fixes a NullPointerException since getServletContext().getResourcePaths(dir) return null when the dir has no files. Saw this inside a .svn directory so the code has also be updated to not go into directories starting with '.'

comment:2 Changed 7 years ago by Nicklas Nordborg

(In [6767]) References #1927: Test BASE with Tomcat 8

JSP compilation error result in a JasperException without any root cause. Need to check for null before replacing the exception or the error page will just be empty.

comment:3 Changed 7 years ago by Nicklas Nordborg

(In [6807]) References #1924, #1927 and #1325. Added information about incompatible changes and things to consider when updgrading to BASE 3.5.

comment:4 Changed 7 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.