Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#2031 closed defect (fixed)

Import function stops with blank page

Reported by: Nicklas Nordborg Owned by: everyone
Priority: major Milestone: BASE 3.10
Component: web Version:
Keywords: Cc:

Description

It seems like the "Import" functionality is broken (at least partially). Clicking the import buttons brings up a dialog with a list of plug-ins/file formats to choose from. Selecting a specific plug-in and file format and clicking "Next" display an empty page with no error message. Opening the debug tools in Firefox reveals a "404 Not found" message in the "Network" tab.

This seems to happen at my development machine only. On the production server the next page is displayed correctly.

Change History (2)

comment:1 Changed 5 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [7201]) Fixes #2031: Import function stops with blank page

Seems like the redirect URL to the new dialog was not generated correctly. Encoding is needed on all string parameters. Don't know why the production server is not affected. Maybe Apache is fixing things...

comment:2 Changed 3 years ago by Nicklas Nordborg

(In [7542]) Incorrect ticket number. Should belong to #2131.

Add support for installing multiple authentication managers

The 'Password' login form was not filling out the dialog due to the <div> element getting set to display: table;.

Last edited 3 years ago by Nicklas Nordborg (previous) (diff)
Note: See TracTickets for help on using tickets.