Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2132 closed task (fixed)

Remove deprecated code in the net.sf.basedb.core.authentication package

Reported by: Nicklas Nordborg Owned by: everyone
Priority: major Milestone: BASE 3.14
Component: core Version:
Keywords: Cc:

Description

There are a lot of code in the net.sf.basedb.core.authentication that was deprecated in BASE 3.3 when the new pluggable authentication system was implemented (#1599).

I think it is time to remove that code now and any other code that may depend on them.

Change History (3)

comment:1 Changed 3 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [7532]) Fixes #2132: Remove deprecated code in the net.sf.basedb.core.authentication package

comment:2 Changed 3 years ago by Nicklas Nordborg

(In [7535]) References #2132: Remove deprecated code in the net.sf.basedb.core.authentication package

Found a reference to a removed class which prevented the extensions system from starting up.

comment:3 Changed 3 years ago by Nicklas Nordborg

(In [7549]) References #2132: Remove deprecated code in the net.sf.basedb.core.authentication package

Found a piece of obsolete documentation.

Note: See TracTickets for help on using tickets.