Opened 3 years ago

Closed 2 years ago

#2138 closed task (fixed)

Officially support Java 11 (or later)

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 3.15
Component: build Version:
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

We should start doing main work with Java 11. The next release should probably be compiled with the Java 11 compiler but with the compatibility option for Java 8 enabled.

See also #2129 and #2139.

Change History (10)

comment:1 Changed 3 years ago by Nicklas Nordborg

Description: modified (diff)

comment:2 Changed 3 years ago by Nicklas Nordborg

Milestone: BASE Future ReleaseBASE 3.15

comment:3 Changed 2 years ago by Nicklas Nordborg

Owner: set to Nicklas Nordborg
Status: newaccepted

comment:4 Changed 2 years ago by Nicklas Nordborg

In 7621:

References #2138: Officially support Java 11 (or later)

Updated to Java 11 in eclipse classpath files. Requries at least Eclipse 2018-12. All seems good but we get a few deprecation warnings, most of them related to Object.finalize().

comment:5 Changed 2 years ago by Nicklas Nordborg

In 7622:

References #2138: Officially support Java 11 (or later)

Added @SuppressWarnings("deprecation") to get rid of warnings. We can't solve the warnings by code as long as we need to support Java 8. So this will have to wait for #2139.

comment:6 Changed 2 years ago by Nicklas Nordborg

In 7630:

References #2138: Officially support Java 11 (or later)

Moved the JAR files that are needed when running under Java 11 to the lib directory so that no special installation is required in this case. It seems to work also with Java 8, but if there are any problems the recommendation is to remove the JAR files and then restart Tomcat:

  • java.activation-api-1.2.0.jar
  • jaxb-api-2.3.1.jar
  • jaxb-core-2.3.0.1.jar
  • jaxb-impl-2.3.1.jar

comment:7 Changed 2 years ago by Nicklas Nordborg

In 7631:

References #2138: Officially support Java 11 (or later)

Updated documentation to recommend Java 11.

comment:8 Changed 2 years ago by Nicklas Nordborg

In 7632:

References #2138: Officially support Java 11 (or later)

Remove misc/java11 directory since it no longer needed.

comment:9 Changed 2 years ago by Nicklas Nordborg

In 7633:

References #2138: Officially support Java 11 (or later)

Removed Class-Path entries in two JAR files since it messes with compilation when the referenced files are not present or have a different name.

comment:10 Changed 2 years ago by Nicklas Nordborg

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.