Opened 2 months ago

Closed 2 months ago

#2247 closed defect (fixed)

Forms.showNotification() only works once in some cases

Reported by: Nicklas Nordborg Owned by: everyone
Priority: major Milestone: BASE 3.18.1
Component: web Version:
Keywords: Cc:

Description

In some cases when there is an error in a form, a notification is displayed with an error message (using the Forms.showNotification() javascript method). If this notification is displayed in response to a mouse click event it may stop working after it has been displayed once.

It seems like the fix to #2210 could be the cause of this since it added the possibility to hide the notification by clicking on the same element again. Thus, the next time the message is about to be displayed there is already another event handler that hides it immediately.

Change History (1)

comment:1 Changed 2 months ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

In 7928:

Fixes #2247: Forms.showNotification() only works once in some cases

Note: See TracTickets for help on using tickets.