Opened 15 years ago

Closed 14 years ago

#632 closed defect (fixed)

BioAssaySetExporter breaks if names of formulas, extra values, raw data propeties not are unique

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.4
Component: coreplugins Version:
Keywords: Cc:

Description

The BioAssaySetExporter? uses the name of the following items to identify things:

  1. reporter properties
  2. raw data properties
  3. formulas
  4. extra values

If more than one item has the same name the export doesn't work as expected. For example, Genepix has a raw data property 'x'. If I have a formula with the name 'x' the export will use the raw data 'x' value and not the formula.

This should be handled differently. The simple solution is to not include items with duplicate names in the list of items to select from (and maybe show a warning message that not all items can be used). A better solution would be to make sure each item can be uniquely identified. The problem is that I think the Base1PluginExecuter relies on being able to use the names to identify what to export.

Change History (2)

comment:1 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [3505]) Fixes #632, #622, #643, #644, #645, #646, #647

Note: See TracTickets for help on using tickets.