Opened 14 years ago

Closed 14 years ago

#657 closed defect (duplicate)

Plug-in wizard may selects wrong plug-in if only one of several plug-ins can be used in a given context

Reported by: Jari Häkkinen Owned by: Martin Svensson
Priority: critical Milestone: BASE 2.4
Component: web Version: trunk
Keywords: Cc:

Description (last modified by Jari Häkkinen)

the affymetrix INTENSITY plug-ins are not recognized. When "New root bioassayset" is selected the dialog goes direct into 2-channel mode, that is requests a formula for importing data.

More info avaialble now. When I added another INTENSITY plugin for Affymetrix, the dialog for selecting a plugin pops up. I am allowed to select either Plier of RMAExpress.

Yes, removing Plier makes the dialog going directly to the formula dialog whereas I would like to see RMAExpress.

Change History (7)

comment:1 Changed 14 years ago by Jari Häkkinen

Description: modified (diff)
Priority: blockercritical

comment:2 Changed 14 years ago by Jari Häkkinen

Description: modified (diff)

comment:3 Changed 14 years ago by Martin Svensson

Owner: changed from everyone to Martin Svensson
Status: newassigned

comment:4 Changed 14 years ago by Martin Svensson

(In [3534]) References #657

comment:5 Changed 14 years ago by Martin Svensson

Resolution: fixed
Status: assignedclosed

comment:6 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: closedreopened
Summary: Affymetrix experiments cannot create a "New root bioassayset" since ...Plug-in wizard may selects wrong plug-in if only one of several plug-ins can be used in a given context

The checked in changes fixes the problem, but it also destroys the fix for #625. The ContextUtil?.checkContext() method must return a ContextResult? object for each plug-in that is tested.

The problem in this ticket is caused by the web client that (incorrectly) assumes that if only one plug-in can be used then it is the first one returned in the list (www/common/plugins/index.jsp line 180-190).

comment:7 Changed 14 years ago by Nicklas Nordborg

Resolution: duplicate
Status: reopenedclosed

Should be fixed as part of #625.

Note: See TracTickets for help on using tickets.