Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#658 closed defect (worksforme)

Invalid request ID: Data in your configuration wizard has become corrupted. Please re-start and try again.

Reported by: Jari Häkkinen Owned by: Martin Svensson
Priority: major Milestone: BASE 2.4
Component: web Version: trunk
Keywords: Cc:

Description

I am trying to start RMAExpress/Plier, but after selecting bioassays and clicking next I get this stack trace:

01:16:18,751 ERROR [jsp]:253 - Servlet.service() for servlet jsp threw exception
net.sf.basedb.clients.web.WebException: Invalid request ID:<br>Data in your configuration wizard has become corrupted. Please re-start and try again.
        at org.apache.jsp.common.plugin.index_jsp._jspService(index_jsp.java:340)
        at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
        at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:334)
        at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
        at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:71)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
        at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
        at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
        at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
        at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
        at java.lang.Thread.run(Thread.java:595)

Change History (4)

comment:1 Changed 14 years ago by Martin Svensson

Owner: changed from everyone to Martin Svensson
Status: newassigned

comment:2 Changed 14 years ago by Martin Svensson

Resolution: worksforme
Status: assignedclosed

comment:3 Changed 14 years ago by Nicklas Nordborg

This is probably caused by the problem described in #688

comment:4 Changed 14 years ago by Nicklas Nordborg

(In [3574]) References #658: Compare requestId as strings instead of integers to avoid problem with integer conversion (see #688)

Note: See TracTickets for help on using tickets.